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Course Name: Full Stack Web Development Professional Certification Program
Course Overview:

Our Full Stack Web Development program is a meticulously designed program tailored to provide
professionals with a comprehensive skill set in both front-end and back-end web development. This
course combines industry-relevant technologies and frameworks to ensure participants acquire a
holistic understanding of full-stack development.

The program begins with a deep dive into foundational web technologies, covering HTML and CSS for
effective web page structuring and styling. Participants will then progress to Bootstrap, mastering
responsive design principles to create adaptable and visually appealing websites.

In the realm of dynamic web development, JavaScript (JS) and jQuery are introduced, enabling
participants to craft interactive web elements, manage events, and manipulate the Document Object
Model (DOM) proficiently.

The backend development module of the program focuses on PHP, a versatile server-side scripting
language, integrated seamlessly with MySQL for robust database management. Participants will gain
expertise in PHP syntax, control structures, functions, and database operations, laying a solid foundation
for server-side web development.

In addition to these core technologies, the program offers specialized training in two modern full-stack
frameworks: MEAN (MongoDB, Express.js, Angular, Node.js) and MERN (MongoDB, Express.js, React,
Node.js). These stacks empower participants to build scalable, efficient, and modern web applications,
reflecting industry best practices.

Practical application is a cornerstone of this program, emphasized through four comprehensive projects
that span across various modules. These projects are designed to simulate real-world scenarios, allowing
participants to integrate and apply their acquired knowledge effectively, thereby building a robust
professional portfolio.

Upon completion of this Full Stack Web Development program, participants will possess expertise in
HTML, CSS, Bootstrap, JavaScript, jQuery, PHP, as well as MEAN and MERN stacks. Designed for
professionals aiming to advance their career in web development, this program offers a structured and
comprehensive pathway to becoming a skilled full-stack web developer in a professional setting.

What You'll Learn?

Upon completion of this Full Stack Web Development program, participants will possess expertise in
HTML, CSS, Bootstrap, JavaScript, jQuery, PHP, as well as MEAN and MERN stacks.
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Duration: 186 hours

1. Html, CSS, Bootstrap, JS, jQuery, PHP (92 hours)

2. 4 Project (12 hours)

3. MEAN and MERN Stack (82 hours)

Requirements:

Html, CSS, Bootstrap, JS, jQuery, PHP, MEAN and MERN Stack
Pre-requisite:

No pre-requisite
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Curriculum

Module 1. Hyper Text Markup Language (HTMLS5)
1. Introduction to HTML

» Understanding what HTML is and its role in web development
2. HTML Basics

» Learning the basic structure of HTML documents
3. HTML Elements

» Understanding various HTML elements like <div>, <span>, <a>, etc.
4. HTML5 Semantic

> Introduction to semantic elements like <header>, <footer>, <article>, <section>, etc. introduced
in HTML5

5. HTML Attributes
> Learning about HTML attributes and how to use them
6. HTML Headings
» Using heading tags <h1>to <h6>in HTML
7. HTML Paragraph
» Using paragraph tags <p>in HTML
8. HTML Styles
> Applying inline styles using the style attribute
9. HTML Formatting
» Learning about formatting tags like <strong>, <em>, <mark>, etc.
10. HTML Quotations
> Using quotation tags like <blockquote> and <q>
11. HTML Computer Code
» Displaying computer code using <code> and <pre> tags

12. HTML Comments & Colors
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» Adding comments to HTML code and using color values
13. HTML CSS, Links and Images
> Linking external CSS, adding images, and creating hyperlinks
14. HTML Lists
» Creating ordered <ol> and unordered <ul> lists in HTML
15. HTML Blocks
» Understanding block-level and inline elements in HTML
16. HTML Classes
» Using classes to style HTML elements with CSS
17. HTML Layout
» Learning about basic page layout techniques using HTML elements
18. HTML Responsive
> Introduction to responsive design principles with HTML
19. HTML iframes
» Embedding external content using <iframe> tags
20. HTML JavaScript
> Including JavaScript in HTML documents
21. HTML Head
» Understanding the <head> section and its importance in HTML documents
Module 2. Cascading Style Sheet (CSS)
1. Introduction to CSS3
» Understanding what CSS is and its role in web development
2. CSS3 Syntax
» Learning the basic syntax and structure of CSS3
3. CSS3 How To
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» Getting started with applying CSS styles to HTML elements
4. CSS3 Colors

> Using color values and understanding color properties in CSS3
5. CSS3 Backgrounds

> Applying background colors, images, and gradients
6. CSS3 Borders

> Styling borders using various properties and values in CSS3
7. CSS Padding

> Understanding and applying padding to elements
8. CSS Height/Width

> Setting and understanding height and width properties
9. CSS3 Gradients

> Creating gradient backgrounds using CSS3
10. CSS3 Shadows

» Applying box shadows and text shadows
11. CSS3 Text

> Styling text properties like font, size, weight, and alignment
12. CSS3 Fonts

» Using custom fonts and font properties in CSS3
13. CSS3 2D Transforms

» Applying 2D transformations like translate, rotate, scale, and skew
14. CSS3 3D Transforms

» Applying 3D transformations in CSS3
15. CSS Links

> Styling hyperlinks and link states
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16. CSS Lists
> Styling ordered and unordered lists
17. CSS Tables
» Styling table elements and their properties
18. CSS Box Model
» Understanding the box model and its properties
19. CSS Outline
> Applying outlines to elements
20. CSS Display
» Understanding and applying display properties
21. CSS Max-width
» Setting maximum width for responsive design
22. CSS Position
» Understanding positioning methods like static, relative, absolute, and fixed
23. CSS Float
> Using float for layout design
24. CSS Inline-block
» Using inline-block for layout design
25. CSS Align
» Aligning elements using various properties
26. CSS Combinators
» Understanding and using CSS combinators
27. CSS Pseudo-class
» Using pseudo-classes to style elements based on state
28. CSS Pseudo-element
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» Using pseudo-elements to style specific parts of elements
29. CSS Navigation Bar
> Creating and styling navigation bars
30. CSS Dropdowns
» Creating dropdown menus with CSS
31. CSS Tooltips
> Creating tooltips using CSS
32. CSS3 Images
> Styling and positioning images using CSS3
33. CSS Attr Selectors
» Using attribute selectors in CSS
34. CSS Forms
> Styling form elements
35. CSS Counters
» Using counters in CSS for numbering
36. CSS3 Animations
> Creating animations using CSS3 keyframes
37. CSS3 Buttons
» Styling and designing buttons using CSS3
38. CSS3 Pagination
» Creating paginated content using CSS3
39. CSS3 Multiple Columns
» Creating multi-column layouts using CSS3
40. CSS3 User Interface
> Styling form elements and other Ul components
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41. CSS3 Box Sizing
> Understanding the box-sizing property
42. CSS3 Filters
» Applying image filters using CSS3
43. CSS3 Media Queries
> Implementing media queries for responsive design
44, CSS3 Responsive
» Implementing responsive design techniques using CSS3
Module 3. Bootstrap
1. Introduction to Bootstrap
» Understanding what Bootstrap is and its role in web development
2. Bootstrap Basics
> Learning the basic structure, classes, and utilities of Bootstrap
3. Bootstrap Grids
» Understanding the Bootstrap grid system for responsive layout design
4. Bootstrap Themes
> Exploring Bootstrap themes and customization options
5. Bootstrap CSS
» Learning and applying Bootstrap CSS classes for styling
6. Bootstrap JS

» Understanding and implementing Bootstrap JavaScript functionalities like modals, tooltips,
carousels, etc.

Module 4. JavaScript
1. Introduction to JavaScript
» Understanding what JavaScript is and its role in web development

2. JavaScript Language Basics
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» Learning basic syntax, variables, data types, and operators

3. JavaScript Objects

» Understanding object-oriented programming in JavaScript and creating objects
4. JavaScript Scope

» Understanding variable scope (local vs. global) and function scope
5. JavaScript Events

» Handling events and event listeners in JavaScript
6. JavaScript Strings

> Manipulating and working with string data
7. JavaScript Numbers

» Understanding number data types and math operations
8. JavaScript Math

> Using built-in Math object for mathematical operations
9. JavaScript Arrays

» Working with arrays, array methods, and iterating through arrays
10. JavaScript Boolean

» Understanding boolean data type and logical operators
11. JavaScript Comparisons

» Comparing values using equality and relational operators
12. JavaScript Conditions

» Using if, else if, and else statements for conditional logic
13. JavaScript Switch

» Using switch statements for multi-way branching
14. JavaScript Loops

> Understanding for, while, and do-while loops
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15. JavaScript Type Conversion

» Understanding automatic and explicit type conversion
16. JavaScript RegExp

» Working with regular expressions for pattern matching
17. JavaScript Errors

> Handling errors using try, catch, and finally blocks
18. JavaScript Debugging

» Using browser developer tools for debugging JavaScript code
19. JavaScript Hoisting

» Understanding variable and function hoisting
20. JavaScript Strict Mode

» Enabling strict mode for better error handling and code quality
21. JavaScript Functions

> Writing functions, function expressions, arrow functions, and understanding scope and closures
22. JavaScript Objects

> Deeper dive into objects, methods, and prototypes
23. JavaScript Forms

» Handling form inputs and validation using JavaScript
24, JavaScript HTML DOM

» Manipulating HTML elements and attributes using the Document Object Model (DOM)
25. JavaScript BOM

» Understanding the Browser Object Model (BOM) and its properties
Module 5. jQuery
1. Introduction to jQuery

» Understanding what jQuery is and its role in web development
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2. jQuery Syntax

> Learning the basic syntax and structure of jQuery
3. jQuery Selectors

» Understanding and using various selectors to target DOM elements
4. jQuery Events

> Handling events and event listeners using jQuery
5. jQuery Effects

> Applying visual effects like show/hide, fade, slide, animate, etc., using jQuery
6. jQuery HTML

» Manipulating HTML content and attributes using jQuery
7. jQuery Traversing

» Navigating and manipulating the DOM tree using traversal methods
8. jQuery AJAX & Misc

» Understanding AJAX methods for asynchronous data retrieval and miscellaneous functionalities
like utility functions, callbacks, chaining, etc.

Module 6. PHP & MySQL
Part 1: PHP Crash Course
1. Using PHP
» Understanding PHP syntax and basic structure
2. Embedding PHP in HTML
> Integrating PHP code with HTML
3. Adding Dynamic Content
» Generating dynamic content using PHP
4. Accessing Form Variables
> Retrieving and handling form data in PHP

Part 2: Storing and retrieving data

Tech Learniversity, 170 1/1, Opposite HDFC Bank, Vijay Nagar,
J.N. Road, Mulund (West), Mumbai-400080, Maharashtra, India
E-mail ID- info@techlearniversity.com , Mobile No. +91-9082949171/+91-7021789240



mailto:info@techlearniversity.com

«D» Tech
Wy Learniversity

QUALITY EDUCATION FROM QUALITY PEOPLE

1. Opening a file

> Reading and writing to files using PHP
2. Writing a File

» Writing data to files
3. Closing a File

> Closing file handles
4. Reading from a File

» Reading data from files
Part 3: Using Arrays
1. Numerically Indexed Array

» Understanding and using numerically indexed arrays
2. Associative Arrays

> Working with associative arrays
3. Sorting Arrays

» Sorting arrays using built-in functions
4. Recording Arrays

» Using multidimensional arrays
Part 4: String Manipulation and Regular Expressions
1. Formatting Strings

» Formatting string output
2. Joining and Splitting Strings

» Using string functions to join and split strings
3. Comparing Strings

» Comparing string values
4. Matching and Replacing Substrings
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» Using regular expressions for matching and replacing substrings
Part 5: Reusing Code and Writing Functions
1. Using require() and include()

» Including and requiring PHP files
2. Using Functions

> Creating and using functions
3. Parameters

» Passing parameters to functions
4. Recursion

» Understanding and implementing recursion
Part 6: Object-Oriented PHP
1. Object-Oriented Concepts

» Understanding OOP concepts in PHP
2. Implementing Inheritance

» Creating and using inheritance in PHP
Part 7: MVC with Laravel
1. Laravel Installation

> Installing Laravel framework
2. Working with Forms

» Handling forms in Laravel
3. Working with Controller

» Understanding and using controllers
4. Laravel Blade Template with Bootstrap

» Integrating Blade templates and Bootstrap
5. Responses with Html
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» Using HTML responses in Laravel
6. Laravel Migration

> Database migrations in Laravel
7. Laravel Requests, Models

» Working with requests and models in Laravel
8. Laravel Eloquent ORM

» Understanding and using Eloquent ORM
9. Build a Complete App in Laravel

> Building a complete web application in Laravel
Part 8: Designing your web database
1. Relational Database Concepts

» Understanding relational database concepts
2. How to Design Your Database & Web

> Designing web databases
3. Database Architecture

» Understanding database architecture
Part 9: Creating your web database
1. Creating Databases and Users

» Creating databases and users in MySQL
2. Introduction to MySQL' Privilege System

» Understanding MySQL privileges
3. Setting Up a User for the Web

» Setting up a user for web applications
4. Creating Database Tables

» Creating tables in MySQL
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Part 10: Working with your MySQL database
1. Inserting, Retrieving and Updating Data
> Performing CRUD operations in MySQL
2. Altering Tables after Creation
» Modifying table structures
Part 11: Accessing your MySQL Database from the web with PHP
1. How Web Database Architectures Work
» Understanding web database architectures
2. Checking and Filtering Input Data
> Validating and sanitizing input data
3. Setting Up a connection & Querying the Database
> Establishing database connections and executing queries
Module 7. MEAN and MERN Stack
Angular (TypeScript)
1. Introduction to Angular
» Understanding the basics and architecture of Angular
2. Angular Application Architecture
» Understanding Angular modules, components, and services
3. What is NgModule
» Understanding Angular modules
4. Angular Components
» Creating and using components in Angular
5. Angular Templates
» Creating templates using Angular syntax
6. Data Binding
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» Understanding data binding and its types
7. Types of Data Binding
> Exploring one-way and two-way data binding
8. Modules Component Working
» Working with Angular modules and components
9. Directives
> Using directives in Angular
10. Structure Directives
» Understanding and using structure directives like nglf, ngFor, etc.
11. Template Routing
» Setting up and configuring routing in Angular
12. Theme Implementation in Angular Framework
» Customizing and theming Angular applications
13. Angular Forms
» Working with forms in Angular
14. Services
» Creating and using services in Angular
15. Inject Services
» Injecting services into components
16. Angular Server Communication With Backend Server
» Making HTTP requests to a backend server
17. Working of APIs(GET, POST, PUT, DELETE)
» Understanding and working with HTTP methods
18. Complete Web Application in Angular Framework - 4 hours
> Building a complete web application using Angular
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Node.js
1. Introduction to Node.js
» Understanding Node.js and its architecture
2. Architecture of Node.js Application
» Understanding Node.js application structure
3. Synchronous and Asynchronous Programming
» Understanding synchronous and asynchronous programming in Node.js
4. Callback Function in Node.js
> Working with callback functions
5. Promises in Node.js
» Understanding and working with promises
6. MongoDB with Node.js
» Connecting and interacting with MongoDB using Node.js
7. Design the Schema in Node.js
» Designing MongoDB schemas
8. Design the Rest API's(GET, POST, PUT, DELETE)
> Creating RESTful APIs using Node.js
9. JSON Web Token Authentication in Node.js
» Implementing JWT authentication
10. Create the Auth APP in Node.js
» Building an authentication app using Node.js
11. Create the E-commerce Backend
» Building a backend for an e-commerce application
12. Integrated Payment Gateway
> Integrating payment gateways with Node.js
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Express.js
1. Express

» Understanding and setting up Express.js
2. Restful services

» Creating RESTful services using Express.js
3. Introducing Express

> Exploring Express.js basics
4. Building your First Web Server

> Setting up a basic web server with Express.js
5. Nodemon

» Using Nodemon for automatic server restarts
6. Environment Variables

> Managing environment variables in Express.js
7. Route Parameters

» Handling route parameters in Express.js
8. Handling HTTP GET Request

» Handling GET requests in Express.js
9. Handling HTTP POST Request

» Handling POST requests in Express.js
10. Calling Endpoints Using Postman

» Testing endpoints using Postman
11. Input Validations

» Validating input data in Express.js
12. Handling HTTP PUT Request

> Handling PUT requests in Express.js
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13. Handling HTTP DELETE Request
> Handling DELETE requests in Express.js
14. Project- Build the Genres API - 4 hours
> Building a complete APl using Express.js
MongoDB
1. Introduction to MongoDB (NoSQL)
» Understanding MongoDB and NoSQL databases
2. Collections in MongoDB
> Working with collections in MongoDB
3. Documents in MongoDB
» Creating and managing documents in MongoDB
4. Difference between MySQL and NoSQL
» Comparing MySQL and NoSQL databases
5. Inserting data into database
> Inserting data into MongoDB
6. Filter queries in MongoDB Database
> Querying data using filters in MongoDB
7. Schema Validation in MongoDB database
» Validating schema in MongoDB
8. Indexing in collections
» Indexing fields in MongoDB collections
9. Aggregation in MongoDB
» Using aggregation framework in MongoDB
10. Embedded Document in MongoDB
>  Working with embedded documents in MongoDB
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React)S
1. Introduction to ReactJS
» Understanding the basics and benefits of ReactlS
2. Understand ReactJS Library & Directory
» Exploring ReactlS library and project directory structure
3. React Components
» Understanding and creating React components
4. Types of Components
> Functional components vs Class components
5. Build a simple React component
» Building a basic React component from scratch
6. Component composition
» Composing components together
7. Component styling
» Styling React components
8. Add styles to your components
> Adding CSS styles to React components
9. Component intercommunication
» Communicating between React components
10. How to pass data from one component to another
» Prop drilling and context API
11. Routing
» Setting up routing in React applications
12. Using Routing to create single-page app
> Creating single-page applications using React Router
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13. Hooks
» Understanding React Hooks and their usage
14. States
» Managing component state
15. Hooks vs States
» Comparing Hooks and States
16. Types of Hooks
> Exploring useState, useEffect, useContext, etc.
17. Redux
» Understanding Redux and its principles
18. Using Redux as a state container for React apps
> Integrating Redux with React applications
19. React Bootstrap
> Integrating Bootstrap with React applications
20. How to deploy ReactJS App

> Deploying React applications to platforms like Netlify, Vercel, or GitHub Pages
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